
The additional features of wsjt-x_improved 

Wsjt-x_improved is an extended version of WSJT-X. I want to stay as close as possible to the original WSJT-X 

with my 'improved' variants. Therefore you will find all basic WSJT-X functions unchanged. Both programs 

are compatible with each other, which makes the switch very easy.  The program settings are automatically 

applied, and also the change back to the original WSJT-X works. The following screen shot gives you a first 

overview of the additional features: 

 
 

Note: After the great success of the mode buttons, we have now also implemented them in the original 

WSJT-X (as of v2.6.0 GA).  



Three different GUIs  

Wsjt-x_improved is always available with three different GUIs: One has WSJT-X's standard GUI (= this is the 

default download), then there is a more compact GUI (= alternative layout, "AL"), and another one is 

optimized for widescreens. The latter two provide a larger Band Activity window, so that you don't need to 

scroll that often. Just try them and see which you like best.  

For technical reasons, each version has its own installer. 

Screen shot of the version with the alternative layout (AL): 

 

 



Screen shot of the widescreen version: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Try out which GUI layout you like best.  

You can also install several program versions side by side by installing them in separate directories (e.g. 

"c:\WSJT\wsjtx_improved", "c:\WSJT\wsjtx_improved_AL", "c:\WSJT\wsjtx_improved_widesreen"), and by 

creating starter hyperlinks on your desktop for the "wsjtx.exe" files located in the respective \bin subfolders. 

Then you can start them as required and make a good comparison.  

Your WSJT-X.ini file with your settings will be recognized and used automatically. 

If you want to run several program instances at the same time, this is also possible. This is described in the 

WSJT-X User Guide. Just in brief: For this, you have to start "wsjtx.exe" with the additional parameter                     

" --rig-name=NAME_XYZ". The program then creates individual .ini files for each instance so that they can be 

operated independently of each other. 

  



Optional band buttons 

Optional band select buttons can be switched on or off in the View menu (as of version 2.7.1). A click on one 

of the band select buttons takes you to your preferred band/mode default frequency, and a right-click sets 

the main DXpedition frequencies. 

 

 

Band select buttons are available for all 3 GUI layouts. This is how it looks with the AL version: 

 

 



Enhanced features for the Wide Graph window 

1. Optional display of bars for Rx and Tx frequency on the waterfall (like JTDX) 

 

 

2. Additional options for the Time stamp on the waterfall: Off / Left / Right 

You can choose to show the timestamp on the waterfall on the left or right, or turn it off.

 

 

3. Improved behavior of the mouse buttons when clicking on the waterfall display 

 Left-click --> set Rx offset (unchanged) 

 Right-click --> set Tx offset (NEW, behaves now like with JTDX) 

 Double-click on right mouse button --> set Rx & Tx offset (Rx = Tx), (NEW feature) 

 Shift + left-click --> set Tx offset (unchanged)  

 Ctrl + left-click --> set Rx & Tx offset (unchanged) 

 

 

  



Alternate Erase button behavior 

When activated, the Erase button behaves like with JTDX: 

 Left-click --> Erase the Band Activity window 

 Right-click --> Erase the Rx Frequency window  

 Double-click on left mouse button --> Erase both windows (unchanged) 

 

 

kHz entry without k 

Especially with EME, where you normally use a bandwidth of significantly more than 5 kHz, you often have to 

change the frequency to other, nearby band segments. You can do this by entering "164k" and pressing 

return, for example. This then changes the frequency from 438.065 MHz to 438.164 MHz, for example.  

When the "kHz entry without k” checkbox is activated, you only need to enter the digits (e.g. on the numeric 

keypad of the keyboard) and can press the Enter key right there. A small but very useful improvement!   



Advanced highlighting options 

I myself use an alternative color scheme, which is easier on the eyes and which is more suitable for the dark 

style due to its more pastel-like colors. As of v2.7.0-rc2, every user can now easily switch between the 

original WSJT-X color scheme and this "wsjt-x_improved" default. With the "wsjt-x_improved" default 

scheme, stations uploading their logbook to LotW will have black foreground color, others red. Stations 

worked B4 are displayed with gray background. 

 

And of course, as before, everyone can customize the color scheme according to their own preferences. 

It is now also possible to highlight individual callsigns or grids according to your specifications. Callsigns 

and/or grids can be highlighted with orange or blue background color. Callsigns/grids must be separated by 

commas and can be mixed (e.g. "K1JT, DG2YCB, JO33, JN58,"). Important: There must be a comma behind 

each callsign (i.e. also at the end of the line).



Wait features 

The "Wait Features" are nice little assistance functions to help finish a QSO more intelligently than calling all 

the time when the other station does not answer, or disappears temporarily due to QSB. 

1. Wait and Reply  

As long as you have the other station's callsign in the DX Call box, Wait and Call will attempt to continue your 

QSO when the station finally answers your call. This also ensures that a second RR73 is sent when the other 

station could not copy your first. Wait and Reply is automatically enabled for modes where Auto Seq is 

available. 

 

Attention: Your rig may be set to Tx when Wait & Reply is enabled. Take the necessary precautions! 

If necessary, right-click on the DX Call button to clear the DX Call box, which disables Wait & Reply. 

Notes: Also, for other reasons, you should not have a callsign in your DX call box longer than necessary for 

the QSO unless you want to observe this station (e.g. using “Highlight DX Call in message”). Consider enabling 

the "Clear DX Call after QSO" option if a right-click on the DX Call button is too much for you. 

  



2. Wait and Call:  

In situations where the QSB is so strong that the other station disappears for an extended period of time, 

Wait and Call can help you. When this feature is enabled, the other station will be called up to three times as 

soon as they reappear on the band with their message containing "CQ", "73" or "RRR". To enable Wait and 

Call, click on the new DX Call button. Wait and Call requires a valid callsign in the DX Call box (= the station 

where you are in QSO with) as well as Auto Seq to be enabled. Any manual intervention, such as pressing the 

Halt Tx or Stop button, will immediately disable Wait and Call, giving you full control over your QSO in any 

case. 

 

"Wait and Reply" and "Wait and Call" are available as of the update 2022-10-07 on. 

Attention: Your rig may be set to Tx when Wait & Call is enabled. Take the necessary precautions! 

 

 

  



3. Wait and Pounce:  

Wait and Pounce lets you respond to incoming CQ messages from other stations. To activate Wait and 

Pounce, select one of the CQ: categories (i.e. CQ: Max Dist or CQ: Max dB or CQ: Min dB) and then right-click 

on the Enable Tx button which then turns orange. In the next over, wsjt-x_improved will answer the CQ 

calling of the most distant / strongest / weakest station. 

 

Wait and Pounce can also be combined with the Filters feature. You can then for example “wait” for CQ 

messages containing a certain prefix, grid, callsign or keyword. 

"Wait and Pounce" is available as of v2.7.0-rc1. 

Attention: Your rig may be set to Tx when Wait & Pounce is enabled. Take the necessary precautions! 

 

 

 

  



Yellow coloring of the "Enable Tx" and "DX Call" buttons 

The "Enable Tx" and "DX Call" buttons are colored yellow if certain incoming messages might switch the Tx 

on. This is always the case in Hound Mode, but also with Wait & Reply or Wait & Call enabled. Some OMs 

had requested this safety feature to remind them to keep their ATU or PA on. If necessary, right-click on the 

DX Call button to clear the DX Call box and thus disable any active Wait function.  

 
 

 

Option to disable the Wait features 

The "Wait features" (Wait & Reply, Wait & Call, Wait & Reply) can be disabled. As there is actually no reason 

why to disable them, they are enabled by default. However, a few OMs have requested this option. 

 

 



Filters 

The Filters give you a powerful tool for customization of what is being displayed in the Band Activity window.  

 

 

There is a Blacklist, a Whitelist, and an Always Pass list. In addition, you can specify up to 4 territories for 

which hiding can be switched on and off directly from the View menu of the main program window. From 

there you can also hide messages from a specific continent or stations worked B4 on band. 

Filter criteria can be combined in any way.  

The Blacklist can for example be used to hide pirate stations, contest messages or messages with unwanted 

content. You can enter whole callsigns, parts of them or keywords. 

A meaningful use of the Whitelist is if you are ONLY interested in messages with certain grids, calls, or 

keywords. All other messages, except those allowed via the Always Pass list, will then be hidden. 

Use the Always pass list to display specific stations even though the respective country or continent is 

hidden. 

You can optionally apply the filters only to the callsigns of the calling stations, or use the filters for Wait and 

Pounce only. In the latter case, all messages will be displayed in the Band Activity window, but Wait & 

Pounce will respond only to stations that meet the set filter criteria.  



As soon as a filter is activated that results in not all decodes being displayed in the Band Activity window, this 

is indicated in the status label (this is the display at the bottom left). It changes from green "Receiving" to 

cyan "Receiving, filter activated". 

 

Filters are automatically disabled for Special Operating modes, so that you don’t accidentally miss a station. 

 



Notes:  As of version 2.7.1, there are more filter options available directly via the main program window. All 

these so-called Quick Filters are now combined in a separate Filters menu. 

And there is a new BP checkbox with which you can (temporarily) bypass all set filters with one click. Very 

useful if you have skipped certain areas (e.g. to display only DX stations) but now want to monitor the entire 

band activity for a certain time. 

 

 

Ignore List 

A click on the Ignore button adds the callsign from the DX Call box to a so-called Ignore list. If you have also 

activated "Ignore stations from the Ignore List", such stations are automatically ignored when you use CQ: 

First, CQ: Max Dist, CQ: Max dB, CQ: Min dB or Wait and Reply.  

You can erase the Ignore List from the File menu.  



Call CQ with an individual contest name 

Optionally, when in contest mode, you can call CQ with an individual contest name instead of “CQ TEST” or 

“CQ RU”. This is particularly useful  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: This wsjt-x_improved function has now also found its way into the original WSJT-X (as of v2.6.0 GA). 

 

 

  



Map grid locators to U.S. States and Canadian Provinces 

Wsjt-x_improved includes also an extra feature introduced by NJ0A. With that, you can let wsjt-x_improved 

map grid locators to U.S. States and Canadian Provinces (useful when working without JTAlert). Current 

limitation: Sometimes the result is only a list of possible States. 

 

 

Search the DX Call on qrz.com, hamqth.com, or qrzcq.com  

 

 Right-click on the Lookup button --> Search for the DX Call on qrz.com 

 Right-click on the Add button --> Search for the DX Call on hamqth.com  

 Right-click on the Ignore button --> Search for the DX Call on qrzcq.com 



MSK144/Q65: Tx until 73 is received 

New option since the Update of February 2023: "MSK144/Q65: Tx until 73 is received". It does what the 

name promises. Quite useful on VHF/UHF/SHF. It increases the success rate for a difficult QSO.  A maximum 

of 10 attempts are made before it times out. Use Wait & Reply in case this is still not enough for you. 

 

 

CQ: First / CQ: Max Dist / CQ: Max dB / CQ: Min dB 

If selected and CQ is called, the program will respond to the first / most distant / strongest / weakest station.  

 

 



Show distance and/or azimuth with grid 

If a station sends a valid Maidenhead locator, wsjt-x_improved now automatically calculates the distance and 

the great-circle azimuth and displays it in the Band Activity pane. 

A new "Align DXCC / distance / azimuth" checkbox allows you to keep the DXCC names (or principal prefixes) 

as well as distance/azimuth in an aligned table form. Two spin boxes allow further configuration of the 

preferred layout: 

 The first spin box sets the number of spaces between the decoded message and the DXCC name (or 

the principal prefix). The default is set to "1", which means one  space more compared to the WSJT-X 

standard. 

 The second spin box sets the number of spaces between the DXCC and the distance/azimuth field. 

You can increase or decrease the default number.  

 The first spin box works also when "Align DXCC / distance / azimuth" is not checked.  It can be used 

to increase the spacing between the decoded messages and the DXCC names. I programmed this 

because the number of stations with non-standard callsigns has greatly increased, and a little more 

space might be appropriate. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Some checkboxes have been repositioned to make it a bit more compact and intuitive. The "Show country 

information for all messages" checkbox has been moved to the General tab and renamed "Show DXCC for all 

messages" so that the three content-related checkboxes are now arranged directly next to each other.  



The following screen shot shows the Band Activity pane with "Show distance in messages with gid", "Show 

azimuth in messages with gid" and "Align DXCC / distance / azimuth" enabled. 

  



Special operating activity to comments 

Check this box to automatically add the Special Operating Activity mode/name to the comments field. For 

example, it adds “NA VHF Contest” or “EU VHF Contest” to the comments. If “CQ with an individual contest 

name” is enabled and a valid abbreviation is entered in the Contest Name field (e.g. “PACC”), this 

abbreviation + “Contest” will be added to the comments (e.g. “PACC Contest”). 

 Note: Retained comments and "dB reports to comments" override this feature.  

 

 
 

  



Diagnostic mode 

Versions from v2.6.0-rc2 upwards have a built-in diagnostic mode. This makes it easy to collect data to 

troubleshoot problems with wsjt-x_improved, or with its communication with your rig (hamlib issues, not 

responding COM ports, etc.). 

 

 

 

Right-click the Tune button to initiate rig tuning (ATU) 

With versions from v2.7.1 "240510" upwards, you can initiate ATU rig tuning directly from the program. 

It is required that your rig is connected via hamlib, and that your rig model supports this feature. 

  



Dark Style  

As of the update 2022-10-07 on, you can switch to dark style directly in the main window. Just click on the 

new item "Use Dark Style" in the "View" menu. This switch does more than restart of wsjtx.exe with the 

parameter --stylesheet :/qdarkstyle/style.qss. Additionally, it adjusts some internal settings and uses an 

optimized stylesheet for the dark style. If you have enabled the dark style, you should adjust the highlight 

color scheme towards pastel tones. Go at Settings to Colors and adjust the background colors according to 

your needs. 

 

  



There is also a PLUS version of each of the 3 versions available, which has 2 additional features: Audible 

alerts (e.g. "New DXCC" or "Calling You") and Cloudlog support. 

Alerts: Very important: Ensure that your rig is NOT connected via "DefaultAudioDevice" !!! 

Use of this feature requires that your computer is equipped with two sound cards. This requirement is 

fulfilled when your rig is connected via USB audio (FT-991, IC-7300, etc.). The audio alerts will be played on 

the default audio device (usually the loudspeaker of your computer) while the normal wsjt-x output is still 

lead to your rig only. 

To configure audio alerts, you will find under "Settings" a new tab "Alerts".  Just select the checkboxes and 

click on “Enable Audio Alerts”. Note that playing of any audio alerts is independent of your settings under 

“Decode Highlighting”. However, audio alerts are only useful for parameters for which "Decode Highlighting" 

is activated. On the other hand, you usually don't want to get an acoustic alert for every optical decode 

highlighting. Useful settings could for example be: 

 



Cloudlog support 

Optionally upload of your QSOs to Cloudlog. Cloudlog is an open-source PHP & MySQL  based amateur radio 

logging application. You can find it at https://www.magicbug.co.uk/cloudlog/. Many thanks to DF2ET for 

programming this feature! 

 

 

 

https://www.magicbug.co.uk/cloudlog/

